Update On Using Old Tech


  So, I've spent a week or two trying to find websites that play video, tv or radio for the old Asus Transformer TF101 but come to find out the tablet's OS is just too old, being Android 4.0.3. Everything now needs, at a minimum 4.4.4. So, what to do with it? I don't need … Continue reading Update On Using Old Tech